Security Advisory – NVIDIA CUDA Toolkit Vulnerabilities April 2024

NVIDIA’s April 2024 security bulletin details vulnerabilities in its CUDA Toolkit and related libraries. CVE-2024-0072 and CVE-2024-0076 affect cuobjdump and nvdisasm, potentially leading to denial of service if a malformed ELF file is processed. CVE-2023-31028 and CVE-2024-0080 involve nvJPEG2000 and nvTIFF libraries, respectively, where improper input validation could also cause service disruption. Updates have been released to mitigate these low-severity risks.

Read the full bulletin