Security Advisory – Multiple Vulnerabilities in NVIDIA GPU Display Drivers (June 2024)

NVIDIA has released a security update addressing several vulnerabilities in their GPU Display Drivers, affecting both Windows and Linux systems. Notable CVEs include CVE-2024-0090, CVE-2024-0089, CVE-2024-0091, and CVE-2024-0092. These flaws could lead to code execution, denial of service, escalation of privileges, information disclosure, and data tampering. Users are urged to update to the latest drivers available on the NVIDIA website to protect their systems.

For more details, visit NVIDIA Support.