Security Advisory – Dell Client Platform NVIDIA GPU Driver Vulnerabilities (CVE-2024-0089, CVE-2024-0091, CVE-2024-0090, CVE-2024-0092)

Dell has issued a security update addressing multiple vulnerabilities in NVIDIA GPU Display Drivers. These flaws could be exploited to compromise affected systems. The vulnerabilities impact various Dell products including Inspiron, OptiPlex, Precision, and Vostro models. Users are advised to update to the latest driver version 30.0.14.7504 to mitigate these risks.

For detailed information and updates, visit Dell Support.