Security Advisory – Critical Vulnerabilities in ABB RobotWare for IRC5 and OmniCore Controllers

ABB has identified two significant vulnerabilities, CVE-2024-1913 and CVE-2024-1914, in RobotWare for IRC5 and OmniCore controllers. These vulnerabilities could allow an attacker to stop the robot, make the controller inaccessible, or execute arbitrary code.

Affected versions:

  • IRC5 RobotWare versions < 6.15.06 (except 6.10.10 and 6.13.07)
  • OmniCore RobotWare versions < 7.14

ABB recommends updating to RobotWare 6.10.10, 6.13.07, 6.15.06, or 7.14 to mitigate these risks.

For more details, please refer to the ABB Security Advisory.