RUSTSEC-2024-0342: Vulnerability in vodozemac

Rust Crates.io Security Advisory


History
Edit
JSON (OSV)

RUSTSEC-2024-0342

Degraded secret zeroization capabilities


Reported
Issued

Package

vodozemac
(crates.io)

Type

Vulnerability

Categories
Aliases
References
Patched
  • >=0.6.0
Unaffected
  • <0.5.0

Description

Versions 0.5.0 and 0.5.1 of vodozemac have degraded secret zeroization capabilities,
due to changes in third-party cryptographic dependencies (the Dalek crates),
which moved secret zeroization capabilities behind a feature flag while
vodozemac disabled the default feature set.

Impact

The degraded zeroization capabilities could result in the production of more
memory copies of encryption secrets and secrets could linger in memory longer
than necessary. This marginally increases the risk of sensitive data exposure.

Overall, we consider the impact of this issue to be low. Although cryptographic
best practices recommend the clearing of sensitive information from memory once
it's no longer needed, the inherent limitations of Rust regarding absolute
zeroization reduce the practical severity of this lapse.

Advisory available under CC0-1.0
license.

READ MORE

Leave a Reply

Your email address will not be published. Required fields are marked *