[R1] Nessus Agent Version 10.4.3 Fixes Multiple Vulnerabilities

Tenable Security Advisory

[R1] Nessus Agent Version 10.4.3 Fixes Multiple Vulnerabilities

Arnie Cabral

Nessus Agent leverages third-party software to help provide underlying functionality. Several of the third-party components (OpenSSL, zlib) were found to contain vulnerabilities, and updated versions have been made available by the providers.

Out of caution and in line with best practice, Tenable has opted to upgrade these components to address the potential impact of the issues. Nessus Agent 10.4.3 updates OpenSSL to version 3.0.12 and zlib fixes have been applied to address the identified vulnerabilities.

Additionally, one other vulnerability was discovered, reported and fixed:

  • Under certain conditions, a low privileged attacker could load a specially crafted file during installation or upgrade to escalate privileges on Windows and Linux hosts. – CVE-2023-5847

READ MORE