Open Social – Moderately critical – Information Disclosure – SA-CONTRIB-2024-005

Drupal Security Advisory

Project: 
Date: 
2024-January-24
Vulnerability: 
Information Disclosure
Affected versions: 
<12.0.5
Description: 

Open Social is a Drupal distribution for online communities.

The included optional social_group_flexible_group module doesn’t sufficiently validate group updates. The lack of validation makes it possible to have content inside the group changing it’s visibility, which could lead to that content being shown to a broader audience than intended.

This vulnerability is mitigated by the fact the module social_group_flexible_group needs to be enabled.

Solution: 

Install the latest version of Open Social:

Reported By: 
Coordinated By: 

READ MORE