[CVE-2024-36682] Exposure of Private Personal Information to an Unauthorized Actor in Promokit.eu – Theme settings module for PrestaShop

PrestaShop Security Advisory

In the module “Theme settings” (pk_themesettings) from Promokit.eu for PrestaShop, a guest can download all emails collected while SHOP is in maintenance mode.

Summary

  • CVE ID: CVE-2024-36682
  • Published at: 2024-06-20
  • Platform: PrestaShop
  • Product: pk_themesettings
  • Impacted release: <= 1.8.8 (see WARNING below)
  • Product author: Promokit.eu
  • Weakness: CWE-359
  • Severity: high (7.5), GDPR violation

Description

Due to a lack of permission control, a guest can access the txt file which collect emails when maintenance is enable which can lead to leak of personal information.

WARNING : Versions declared as impacted are versions where we confirmed critical issue. Author don’t know which exacts versions are impacted, he only said us that it was a long time ago. Author refuse to provide the last version to let us check that all is fixed. So you should consider that all versions can be impacted.

CVSS base metrics

  • Attack vector: network
  • Attack complexity: low
  • Privilege required: none
  • User interaction: none
  • Scope: unchanged
  • Confidentiality: high
  • Integrity: none
  • Availability: none

Vector string: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Possible malicious usage

  • Steal personal data

Timeline

DateAction
2024-03-30Issue discovered during a code review by TouchWeb
2024-03-30Contact Author to confirm version scope
2024-03-30Author don’t know which version is impacted but confirm us that it was a long time ago
2024-03-30Author refuse to provide us the last version to check if it is fixed
2024-06-06Received CVE ID
2024-06-20Publish this security advisory

READ MORE

Leave a Reply

Your email address will not be published. Required fields are marked *