CVE-2024-22411 (avo): Cross-site scripting (XSS) in Action messages on Avo

Ruby Security Advisory

Avo is a framework to create admin panels for Ruby on Rails apps.
In Avo 3 pre12 any HTML inside text that is passed to `error` or
`succeed` in an `Avo::BaseAction` subclass will be rendered directly
without sanitization in the toast/notification that appears in the
UI on Action completion. A malicious user could exploit this
vulnerability to trigger a cross site scripting attack on an
unsuspecting user.

This issue has been addressed in the 3.0.2 release of Avo. Users
are advised to upgrade.

READ MORE