CrushFTP VFS Sandbox Escape Vulnerability (CVE-2024-4040)

Fortiguard Security Advisory

What is the Vulnerability ?
A zero-day security vulnerability has been uncovered in an enterprise file-transfer software CrushFTP. The vulnerability tagged as CVE-2024-4040 is actively being exploited in targeted attacks and has also been added to the CISA Known Exploited Vulnerabilities (KEV) list. The vulnerability allows unauthenticated remote attackers to read files from the file system outside of the VFS Sandbox, gain administrative access, and perform remote code execution on the server.

What is the recommended Mitigation?

According to the vendor advisory, CrushFTP versions prior to 10.7.1 and 11.1.0 are vulnerable to CVE-2024-4040 and being advised to immediately apply the patch.

What FortiGuard Coverage is available?
Endpoint vulnerability service is available to help detect vulnerable endpoints running the CrushFTP server application. FortiGuard Labs is further investigating for additional coverages.

READ MORE

Leave a Reply

Your email address will not be published. Required fields are marked *