Cisco Adaptive Security Appliance and Firepower Threat Defense Software VPN Packet Validation Vulnerability

Cisco Security Advisory

A vulnerability in the AnyConnect SSL VPN feature of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an authenticated, remote attacker to send packets with another VPN user’s source IP address.

This vulnerability is due to improper validation of the packet’s inner source IP address after decryption. An attacker could exploit this vulnerability by sending crafted packets through the tunnel. A successful exploit could allow the attacker to send a packet impersonating another VPN user’s IP address. It is not possible for the attacker to receive return packets.

Cisco has released software updates that address this vulnerability. There are no workarounds that address this vulnerability.

This advisory is available at the following link:
https://sec.cloudapps.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-asa-ssl-vpn-Y88QOm77

Security Impact Rating: Medium

CVE: CVE-2023-20275

READ MORE